Partial blackhole outage
Incident Report for DNSWatch
Resolved
Issues with the blackhole not responding have been resolved. The backlog of customer alerts has been processed.

All DNSWatch services are fully operational.
Posted Apr 30, 2019 - 09:44 EDT
Investigating
We are investigating an ongoing issue with DNSWatch. Customers are intermittently unable to see their customized block page when visiting a blocked domain. Customer alerts may be delayed in appearing in the dashboard.

All other services, including DNS, are fully operational. Despite not being able to see the block page, customers are still protected.
Posted Apr 30, 2019 - 09:01 EDT
This incident affected: Blackhole.