DNSWatch Dashboard Outage
Incident Report for DNSWatch
Resolved
The DNSWatch Dashboard was unavailable for approximately 1-2 minutes due to a large spike in database load.

All DNSWatch services are fully operational. We are continuing to investigate the root cause of the spike in load.
Posted Nov 02, 2018 - 13:37 EDT
Update
The DNSWatch Dashboard is now fully operational.
Posted Nov 02, 2018 - 13:21 EDT
Investigating
The DNSWatch Dashboard is currently unavailable. We are investigating the issue.

We apologize for any inconvenience this is causing.
Posted Nov 02, 2018 - 13:19 EDT
This incident affected: Dashboard.