Miscategorized CDN domains
Incident Report for DNSWatch
Resolved
This incident has been resolved. The two miscategorized domains are now accurately categorized as "Information Technology".
Posted Mar 04, 2020 - 17:34 EST
Update
We are continuing to work on fixing this issue.

1) e673.dsce9.akamaiedge.net - miscategorized as "Malicious Web Sites". This is impacting iTunes related services.
2) appleid.apple.com.akadns.net - is now correctly categorized at "Information Technology".

We continue to suggest manually whitelisting apple.com in the DNSWatch dashboard if you are unable to access Apple related services. You can do this at the following link:

https://dnswatch.watchguard.com/domains/whitelist/

We will continue to update this incident.
Posted Feb 28, 2020 - 16:10 EST
Identified
We have received reports of Apple related domains being unexpectedly content filtered by DNSWatch. While investigating, we discovered that specific Apple domains CNAME to domains used by content delivery networks. These content delivery network domains are miscategorized.

1) e673.dsce9.akamaiedge.net - miscategorized as "Malicious Web Sites". This has been fixed and is now categorized correctly.

2) appleid.apple.com.akadns.net - miscategorized as "Phishing and Other Frauds". This is ongoing and still miscategorized.

We have identified the root cause of this issue and are working to correctly categorize the second domain. Until then, we suggest manually whitelisting apple.com in the DNSWatch dashboard if you are unable to access Apple related services. You can do this at the following link:

https://dnswatch.watchguard.com/domains/whitelist/

We will continue to update this incident.
Posted Feb 24, 2020 - 13:21 EST
This incident affected: Content Filtering.