Large number of blackholed connections impacting blackhole performance
Incident Report for DNSWatch
Resolved
An ad domain (agkn[.]com) was erroneously added to the DNSWatch blacklist which caused a spike in traffic to the blackhole. DNSWatch has finished procesing a backlog of alerts.

All systems are currently operational. DNSWatch continued to protect customers throughout this incident.
Posted Jan 16, 2020 - 17:23 EST
Investigating
We are currently investigating a very large spike in blocked traffic. This traffic is impacting the performance of the blackhole.

Customers visiting blocked domains may not see a block page.

We will update this issue as we continue to investigate.
Posted Jan 16, 2020 - 16:51 EST
This incident affected: Blackhole.