Blackhole Outage
Incident Report for DNSWatch
Resolved
This issue is now resolved.
Posted Jul 15, 2020 - 09:48 EDT
Investigating
We are investigating an issue with the Blackhole service. Alerts are currently delayed.

All other services are operational. Customers remain protected during this incident.
Posted Jul 14, 2020 - 18:45 EDT
This incident affected: Blackhole.