DNS timeouts and long response times
Incident Report for DNSWatch
Resolved
This incident has been resolved.
Posted Nov 07, 2018 - 14:26 EST
Update
Our monitoring indicates zero timeouts or failed queries since 18:47:45 UTC yesterday. At this point in time, all DNSWatch services are fully operational.

We are continuing the investigate the root cause of this issue and will share more information as it becomes available.

We apologize for any inconvenience this has caused!
Posted Nov 01, 2018 - 12:03 EDT
Update
We are continuing to investigate this issue, but have made a number of changes to reduce the number of timeouts and response time for our DNS infrastructure.

As of 18:47:45 UTC, our monitoring reports zero timeouts or failed queries.
Posted Oct 31, 2018 - 15:38 EDT
Investigating
We are currently investigating occasional timeouts and long response times for US based DNS services behind 54.174.40.213.
Posted Oct 31, 2018 - 13:47 EDT
This incident affected: DNS (DNS (US)).