False positives domains being blocked
Incident Report for DNSWatch
Resolved
All systems are operating as normal. E-mail notifications are working, the blackhole is responsive.

Throughout this incident customers have continued to be protected and DNS resolution was unaffected.
Posted Dec 19, 2019 - 16:37 EST
Update
Due to the large number of e-mails sent, DNSWatch is currently unable to send additional e-mails.

This currently impacts any notifications sent by DNSWatch: notifications about networks, alerts, or inviting users.
Posted Dec 19, 2019 - 15:05 EST
Update
Customers may see a large amount of false positive alerts. The data processing was delayed due to the influx of data from false positives. The process of the backlog of data has completed and all systems are operating normally.
Posted Dec 19, 2019 - 14:19 EST
Monitoring
One of the sources of malicious domains that DNSWatch ingests added many false positive domains today. Customers may have been blocked trying to visit legitimate sites.

The false positives have been removed from DNSWatch, but it might take a some time for DNS caches to clear. Due to the increased load, the blackhole is currently responding slowly and may appear down for periods of time. We are working to remedy this as quickly as possible.

We have disabled that source of malicious domains until further evaluation can be performed.

Customers have continued to be protected throughout these event although they may not see the block page due to the increased load on the blackhole. DNS resolution and other services have not been affected.
Posted Dec 19, 2019 - 12:41 EST
This incident affected: Dashboard and Blackhole.