Poor Dashboard and Blackhole Performance
Incident Report for DNSWatch
Resolved
Performance issues with the Dashboard and Blackhole have been resolved.

All DNSWatch services are fully operational.
Posted Apr 30, 2019 - 11:43 EDT
Investigating
We are currently investigating the cause of poor performance in the DNSWatch Dashboard and Blackhole. You may experience timeouts when accessing the Dashboard.

Note, all other services are fully operational. You remain protected despite this issue.
Posted Apr 30, 2019 - 11:07 EDT
This incident affected: Dashboard and Blackhole.