Increased DNS response time in EU/Ireland region
Incident Report for DNSWatch
Resolved
We have identified and fully resolved an issue causing increased DNS response times in the EU/Ireland region.
Posted Sep 04, 2020 - 10:17 EDT
Investigating
We are currently investigating increased DNS response times in the EU/Ireland region.
Posted Sep 01, 2020 - 12:26 EDT
This incident affected: DNS (DNS (EU)).