DNSWatch block pages currently unavailable
Incident Report for DNSWatch
Resolved
This incident has been resolved.

The DNSWatch block pages were unavailable yesterday for approximately five hours, between 3:00PM and 8:00PM Eastern. Additionally, DNS reporting data was not captured during this time.

DNSWatch protection and recursive DNS were unaffected.
Posted Mar 27, 2019 - 15:31 EDT
Monitoring
The DNSWatch block pages are currently unavailable. If you visit a malicious web page, you will not see the DNSWatch block page.

We have identified the root cause and are working to restore services.

Note, you are still fully protected. All other DNSWatch services are operational.
Posted Mar 26, 2019 - 17:21 EDT
This incident affected: Blackhole.