Blocking sharepoint.com related domains in error
Incident Report for DNSWatch (formerly Strongarm)
Resolved
This incident has been resolved.
Posted Oct 30, 2019 - 16:45 EDT
Monitoring
Earlier today the domain spo-msedge[.]net was added to the DNSWatch blacklist in error. The domain in question was reported to our analysis team in suspicion of hosting phishing pages. The domain is actually used for Microsoft Sharepoint Services and should not have been blocked with DNSWatch.

Our team noticed an increase in traffic to this domain immediately after it was erroneously blocked. Upon realizing our mistake, the domain was removed, alerts were labeled as false positives, and we began communicating with customers that may have their day-to-day business negatively impacted by having Sharepoint blocked.

The domain in question was blocked for approximately 20 minutes at 12:30PM Eastern time. Due to how DNS caches operate, some customers may still experience Sharepoint being blocked. If this is happened, we suggest contacting us for assistance.

We will continue to monitor this incident and provide updates. We sincerely apologize for this inconvenience.
Posted Oct 09, 2019 - 15:45 EDT
This incident affected: DNS (DNS (US), DNS (EU), DNS (APAC/Tokyo), DNS (APAC/Sydney)) and Blackhole.